Screwfix website not accessible

UKworkshop.co.uk

Help Support UKworkshop.co.uk:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

Setch

Established Member
Joined
18 Jan 2009
Messages
681
Reaction score
169
Location
London UK
Is anyone else unable to see the screwfix website? I get what seems to be a DNS error when I try to go there, both by following links or manually entering the URL. My wife has the same issue on her phone.

It's been nearly a week now, and I find it inconceivable that a large retailer could have website outage for that long?!
 
I just get a blank page over the last week. It works on a different browser like Chrome though. I think they have messed around with it but haven't tested it on other browsers.
 
No prob. Just been on and went to pick up in their new shop in Ashbourne. New Toolstation next door also, which I didn't know
 
Probably want to clear your cache. Trouble is you loose all your cache items which include saved passwords.

Alternately you could try clearing your DNS cache.
 
Is anyone else unable to see the screwfix website? I get what seems to be a DNS error when I try to go there, both by following links or manually entering the URL. My wife has the same issue on her phone.

It's been nearly a week now, and I find it inconceivable that a large retailer could have website outage for that long?!
Fine for me. I bet your ISP's DNS servers are having "issues". You could always use OpenDNS's or Google's - either at the device level or at the router level (better in the long run).
 
Fine for me. I bet your ISP's DNS servers are having "issues". You could always use OpenDNS's or Google's - either at the device level or at the router level (better in the long run).
Give this man a prize! Looks like this is a Plusnet issue, as switching from wifi to 4G magically fixes the problem.
 
There was a notice on the home page about changes and some browsers not working - that first appeared about 6 weeks ago IIRC. Has worked OK for me - now with what seems a different layout on the home page.
 
Reboot router. Ideally switch off for couple of inures and remover. Then restore power and boot up..

clearing cookies often is enuff but not always..

lice wise reboot computer often fixes it.

but router is usual suspect, if the isp isn’t having dnsproblems
 
Mine's ok, I just googled S/F, but google also showed this thread. A problem I get is when using Sainsburys on line, if I use google chrome I have to have a texted code, but not if using Firefox. If I use chrome to shop I'm forever getting "Oops! Snap!", but never when I use Firefox, JS are no good at fixing this, nor are any other suggestions online, therefore I always use Firefox. The cookies banners are the biggest PITA, having to keep clicking them off.
 
Reboot router. Ideally switch off for couple of inures and remover. Then restore power and boot up..

clearing cookies often is enuff but not always..

lice wise reboot computer often fixes it.

but router is usual suspect, if the isp isn’t having dnsproblems
Obviously one ought not to “type“ when still under effects of anasthaesia…. And even more so on a not so smart fone…

“lice“ should have been “like”,
 

Latest posts

Back
Top