Axminster thickness and planner trade machine

Help Support

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


New member
15 Feb 2019
Reaction score
I've got an Axminster trade thickness and planer with blades not spiral cutters.

All of a sudden when you put a piece of wood through the thicknesser the rollers grab the piece of wood and guide it through to the other side. Now it goes so far through and then stops on the second roller and you have to give it a push to help it through. Yet both rollers are running. Why?
Have you tried cleaning and waxing the bed. I have a Hammer thicknesser and planer that does this and needs the bed lubricating regularly. Otherwise you might have to look into adjusting the pressure of the outfield rollers.
As Alli said. Thoroughly clean the bed. I use Liberon Wax and Polish Remover with 0000 wire wool (thank you Matt Estlea). Wipe clean then liberally apply WD40 and medium (maroon) scotchbrite pad worked across the bed in straight lines. Wipe and repeat. Finally wipe clean and apply machine wax and buff with a cloth. You won’t stick now! Don’t do this every time you use it but regular waxing helps a lot.
You may also find that the rollers need a clean - accumulated dust + age means that the friction required to drive the wood through has declined with time.

Meths not wax is recommended.
Our planer thickness has a habit of doing this too, it is easily cured (as others have said) with a good clean and polish to the bed - I even give it a spray with silicone, (i know, tut tut tut)