Quantcast
  • We invite you to join UKWorkshop.
    Members can turn off viewing Ads!

My mitre saw's packed in

UKworkshop.co.uk

Help Support UKworkshop.co.uk:

Unib

Established Member
Joined
10 Jan 2012
Messages
157
Reaction score
0
Location
Sheffield
Bit of long shot but...

I have an Axminster QMS254I mitre saw (the one with the induction motor) which has packed in. It was working fine, I put in on the floor - put it back on the bench and that was it. The motor tries to turn but it just turns a small amount every time you press the go button - it's like something's jammed in it. Obviously I've tried taking the blade off and had it down to the spindle but it still does the same thing. Don't s'pose anyone has any idea what it might be?

Next question - do Axminster do repairs? Or anyone know of anywhere near Sheffield that might be able to fix it?

Be a real shame to have to scrap it 'cause it's a great saw :(
 

Unib

Established Member
Joined
10 Jan 2012
Messages
157
Reaction score
0
Location
Sheffield
Cheers Ian, that would be be great. I'm in S8 so pretty close - could bring it over to you

flh801978":3jvklp9f said:
I'm in sheffield I can at least diagnose whats needed
I'm in S7

Ian
 

Unib

Established Member
Joined
10 Jan 2012
Messages
157
Reaction score
0
Location
Sheffield
Hi Ian,

I haven't – I got your number but I've been flat out busy all week and totally forgot to give you a call – I shall do once today's out of the way!

Cheers

flh801978":29jthfvo said:
Did you sort it?
I pmed you my number but not heard from you
Ian
 
Top