• We invite you to join UKWorkshop.
    Members can turn off viewing Ads!

Imac and Steve Maskery DVDs - Problems ?

UKworkshop.co.uk

Help Support UKworkshop.co.uk:

Grahamshed

Established Member
Joined
14 Apr 2012
Messages
3,066
Reaction score
0
Location
Oxfordish
Just wondering if anyone has found a problem watching the Workshop Essentials DVDs on an Imac ?

I got the jigs and bandsaw set ( 1,2,4,5,6 ) the other day and have watched 4, 5 & 6 without any problem until I came to watch them again. With No 4 I got a message on screen saying it was skipping over errors, but apparently the whole disk was in error. Disks 5 and 6 were not recognised by the computer despite the fact it had already shown them once.

I have dropped Steve a message using his site contact form but have little confidence in getting a reply. I have often used these website contact forms and have never had a reply from one. I am not sure Safari is dealing with them correctly.

I have no doubt the disks are/were ok and am wondering if this has happened to anyone else using apple ?
 

marcros

Established Member
Joined
11 Feb 2011
Messages
11,301
Reaction score
731
Location
Leeds
Graham,

there was a thread a day or two back warning that Steve may be having a couple of issues with broadband. Cant help on the other issue though.

Oh, and i think immac is now "veet"
 

Oryxdesign

Established Member
Joined
30 Dec 2007
Messages
1,716
Reaction score
0
Location
Kent, UK
You may have some dust in your DVD player?

You could send Steve a PM on here.
 

Blister

Established Member
Joined
10 Nov 2006
Messages
6,776
Reaction score
128
Did you put finger marks on the back of the DVD ? , I would try cleaning the disc with some lens cleaner , just a gentle wipe will make sure the surface is clean

I have a Imac and have had no problems with the player , but don't have Steve's DVD's
 

Steve Maskery

Established Member
Joined
26 Apr 2004
Messages
11,795
Reaction score
142
Location
Kirkby-in-Ashfield
Hi Graham
I'm sorry to hear you are having problems. They should play as well on a Mac as on a PC.
I do occasionally get bed disks, but if you have 3 in one set I suggest that the problem lies elsewhere. At 3% that is 1 in 30,000! When did you buy them please? I can't find a recent record of a sale to anyone called Graham...

S
EDIT _ I do not have a PM from you, nor any email from my site. But you can email me directly, [email protected] or call 07961 427955.
 

Grahamshed

Established Member
Joined
14 Apr 2012
Messages
3,066
Reaction score
0
Location
Oxfordish
Hi Steve.
I received the pack earlier this week. The name is Graham Hall.
I also do not think it is/was the disks at fault. The 3 I have played so far ( 4,5,6 ) worked perfectly the first time. It was only when I went back to 4 to rewatch the bandsaw set up bits that I found the problem.

I do not think I got any finger prints on them, nor do I think it is dust in the player or they wouldn't have played the first time.

Not sure what to do, I think I will have to try them again but I am concerned about damaging them further, if that is what I have done.

I emailed you through your contact page this morning, but as I said, I never seem to get answers doing that so I do not believe they work with safari.
 

Oryxdesign

Established Member
Joined
30 Dec 2007
Messages
1,716
Reaction score
0
Location
Kent, UK
Grahamshed":kym18hck said:
Hi Steve.
I emailed you through your contact page this morning, but as I said, I never seem to get answers doing that so I do not believe they work with safari.
I have contacted Steve via his site in the past and I use safari.

I had an intermittent fault on my very old iMac and it turned out to be dust on the lense. I didn't do anything about it for ages, until it stopped working completely, in desperation I gave it a quick puff with the airline and it's been fine since.
 

JakeS

Established Member
Joined
25 Oct 2011
Messages
947
Reaction score
1
Location
Grantham
Steve Maskery":3d223xab said:
I can't find a recent record of a sale to anyone called Graham
...
I do not have ... any email from my site.
Did you buy them from workshopessentials.com or workshopessentials.ch? ;-)


Seriously, dodgy DVD drive is my bet as well - have you tried any other DVDs?


(One thing you may try is downloading VideoLAN Client and playing them through that. I find it copes better with read errors better than iDVD, although the interface is unfortunately appalling.)
 

Grahamshed

Established Member
Joined
14 Apr 2012
Messages
3,066
Reaction score
0
Location
Oxfordish
To update this.

I tried the disks again with the same result. I then tried them all again and they all worked.
Go figure.

In the process of doing that I noticed I have a sticky cmd key on the keyboard, stays down when pressed. maybe it was stuck down and that was causing the problem.

I would like to say a big thank you to Steve Maskery who, having read this thread, went to the trouble of phoning me to discuss the problem. That is customer service above and beyond the call of duty. t was much appreciated Steve.
 
Top