Jet AFS-500 air filter PCB repair – help please.

Help Support

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.
Hi I'm having a similar problem I have the afs 1000b It will not switch on via the remote but I can turn on manually there is no loss of power on all 3 speeds just the remote will not work is it the pcb board or could it be the remote the batteries are brand new please help thanks for any help
Just fixed mine using the ebay part linked. Very useful to have found this topic or I might of ended up buying a new one.
My Jet AFS 500 had the same symptoms as described earlier in this topic chain. I replaced capacitor C2 with recommended one, as sold on Ebay, and the filter now works flawlessly. IMO it works much better than when it was brand new.
Many thanks to Jack for solving this for me.
Cheers Dave
Glad this fix worked for you too. Thanks for letting us know.
I've had a AFS500 for a few years. It's stopped working recently and I suspect the circuit board. This will be the third one. Axminster supplied the first then then second was half price. I think I'm going to try the eBay capacitor this time.

Will let you know how I get on.

Thanks for all the input here without it I don't think I would have Been able to attempt a repair.

Well, attempted the repair but still no luck.

Axminster want £61 for a new board. This will be the third board I have purchased so the forth this unit has had. I have asked if they will do me a deal as it's clearly a week part.

I await their response.

Not sure I will pay that for another board, may just look around for a filter from another manufacturer.


I've been thinking of just wiring up some sort of 240v speed dial and bypassing the board altogether Just need to find one that can take the current, anyone any ideas? I don't need the timer, just on / off and speed.

I'd try contacting jet and send em a link to this thread. They should atleast be aware of the issue then.

Sent from my SM-G900F using Tapatalk
Hi Mick,
Sorry to hear that replacing the capacitor didn’t fix it.

Does the fan turn at all; do any of the LEDs illuminate (even if only dimly); and are there any beep responses to the remote control or PCB switch presses?

I think the small black rocker switch alongside the cable entry is to manually reset a 3 amp circuit breaker, has that tripped out?

Thanks for clarifying that.
If the circuit board is to hand it might be worth a quick visual inspection of the fuse marked F1 on the PCB to see if that has blown (but I bet you’ve already done that).
Sorry but I don’t know if the electronic speed regulator would work.
Axminster as a 'good will gesture' have offered to replace the board with a discounted price and free postage so I will take them up on that. Don't save a fortune but it's better than nothing. As I understand it the current boards are an upgraded version.

Time will tell.

Any change of a photo of both sides of the board when it comes? I would like to see the "upgrades"

New circuit board arrived this morning. A five minute job to fit and to my relief all is now working again.

Quick turnaround by Axminster and a bit of a discount.

It looks like they have changed the capacitor but I'm not sure what other parts have been changed / upgraded.

Pics of new board both side as requested by Pete.

Circuit Board Top.jpeg

Circuit Board Bottom.jpeg



  • Circuit Board Top.jpeg
    Circuit Board Top.jpeg
    106.8 KB · Views: 136
  • Circuit Board Bottom.jpeg
    Circuit Board Bottom.jpeg
    123.4 KB · Views: 136
This is still a problem. I bought my AFS-500 in July 2014. Died in November 2016. The PCB was replaced by Axminster free of charge. The replacement board was the one shown above, with the yellow C1. Died for the second time a couple of days ago. I bought the capacitor from the ebay seller whose listing is Repair Faulty JET AFS-500 1000 Air Dust Filter 1uF EPCOS Capacitor fix, mentioned earlier in the thread. Ordered Thursday, delivered Saturday, fixed just after lunch.

The capacitor on the PCB may be rated at 310V, but it doesn't seem to be up to the job.