Drill press (ATDP17F) tripping


Help Support UKworkshop.co.uk:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.


Established Member
30 Jan 2008
Reaction score
Hi, long time member, not been around in ages!

I've got an Axminster drill press. ATDP17F. I've barely ever used it and now that I've actually had need for it a few times in a row its suddenly decided to trip the workshed consumer unit every time after running for a few seconds.

Has anyone had similar and know what to check please?

I looked at the wiring in the on off switch area and it all looks good condition. Not sure how to delve deeper.

It's 750w on a regular 13 amp (which the manual says is fine). I've tried it in another socket, same problem. Nothing else is tripping.

This sounds like there might be an insulation issue due to dampness in the motor which is causing an RCD to trip on imbalance due to an earth leakage.
Thanks I'm reading up on that and if there's anything simple I can do without knowing much about it. Same shed has other machinery which has never had issues. I'm hoping if I can work out how to open it up a bit I might spot something.
If this machine was working ok and now after a period of time it trips the RCD it can only be damp or mice !! Give it a good inspection and look to ensure everything looks ok and then you could try a warm air heater on the motor. I am assuming that you have checked it rotates and maybe take the belt off .
There is a manual for it here:


which has an electrical diagram.

What to do depends on the electrical competence and confidence of the OP.

If it were mine, I would disconnect the motor from all other parts of the machine, wire up a lead direct to the motor and try it. If it continues to trip, the fault is within the motor (a stuck centrifugal switch, as above is a very good first place to look if this is the case).

If the motor runs without tripping, the fault lies elsewhere.

Try it on an extension lead from the house (which will be fed from a different breaker) just to eliminate the possibilty of something being fussy on the supply side.

You say 'nothing else is tripping' which is strong evidence, but not conclusive - possibly the particular/peculiar characteristics of the drill is enough to interact with a marginal breaker in the shed CU and push it over the edge.
I've found that a small amount of water was in the bottom of the protective cap which houses a capacitor, on the back of the motor. I'm guessing that means it's likely damp inside the motor too?

No idea how it got there. No signs of a shed leak.

It's RCD which is tripping by the way. A BG CUR4030.

I can't easily run house power down it's 40m away.
Last edited:
It has now worked twice (ran under tension) since emptying a cm or 2 dirty looking water from the bottom of the capacitor cover..

Could that water have gathered there due to the capacitor/motor as opposed to there being some very strange shed leak somewhere which managed to only end up in that small area?
Last edited:
Thanks, I'm now reading up on work shed condensation..
Last edited:

Latest posts