What’s this called (Erbauer ER2100), help!

UKworkshop.co.uk

Help Support UKworkshop.co.uk:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

Woodwork Journey Dean

Established Member
Joined
30 Jan 2022
Messages
94
Reaction score
101
Location
Norwich UK
I picked up a second hand Erbauer ER2100 to go into a router table today. Noob issue and didn’t get the chap to plug it in. It may or may not have worked at this point.

I stripped it in order to make an above table lift. In the process the bushes came out and broke, but so did this what I believe may be a ferrite ring magnet that sits at the top of the motor column

IMG_9086.jpeg


It broke in two, and while trying to see if 2 part epoxy would stick it back together, I properly broke it.

IMG_9091.jpeg


The reason I was unsure if it worked when I picked it up is because of the burning where the bushes go in the plastic housing

IMG_9088.jpeg



Anyway, I’ve ordered some brushes that will hopefully fit, but I’m assuming the broken ring thing needs replacement, even though I have no idea what it does.

Will it run without it?

Any idea where I could find the possibly ferrite ring thing? Google gives me nothing close to the size.

I’m in the lookout for a broken ER1200 to scrounge for parts.

But this is how it looked to begin with, seemingly hardly touched!

IMG_9059.jpeg
 
It is a magnet used in the feed back for the speed control. It is essential and needs to be the correct part as the number of poles will be important to correct operation.
 
I had a similar problem with a Dewalt 625 E variable speed router a couple of years back.......I knew the bearings were starting to go on it, as I had used the router quite intensively for some time.
I was right in the middle of a job, and the bearings were screaming but I had to plough on to get the job finished.
When I eventually got around to stripping the thing apart to fit new beatings, that graphite ring had welded itself to the casing due to the heat/friction created by the overheated bearings.....I tried to remove the ring but it just disintegrated......In the end, I just reassembled the router after fitting the new bearings without the ring and it still works, .....but only at full speed!......It no longer has variable speed control.

I've not found it an issue, due to the fact that that particular router is dedicated to a specific task that always requires it to be run at maximum RPM......
 
Back
Top