• We invite you to join UKWorkshop.
    Members can turn off viewing Ads!

Jet 1220vs.......

UKworkshop.co.uk

Help Support UKworkshop.co.uk:

NikNak

Established Member
Joined
9 Aug 2008
Messages
741
Reaction score
15
Location
Southampton
Hi all,


I've been down the shed using my Jet 1220vs, no problems performed well as always..... :)

Except all of a sudden it starts spinning at full throttle and cant slow it down other than to switch it off..... :shock:

Anyone else with one of these lathes had a similar experience..?? :?

Just checked on Ax's website to see if there's anyone there today (it was worth a try...) Will have to ring them in the morning and speak to tech/warranty guys.....



Nick
 

NikNak

Established Member
Joined
9 Aug 2008
Messages
741
Reaction score
15
Location
Southampton
Just to let you know i rang Axminster this morning and spoke to Ian in technical support....

He's never heard of this before (i even googled it last night to try and find anyone with similar experiences), explained what happened etc. and the nice man is going to arrange collection, if i cant find a suitable packing case to put it in then it'll be collected via their own transport.

He asked how long i'd had it and i said it's about 10 days out of warranty... :cry: "that's not a problem... we'll get it fixed for you" says he..... i hope i'm about to experience their amazing after sales customer care..... =D>


I'll keep you all updated




Nick
 

Paul Hannaby

Established Member
Joined
1 Sep 2011
Messages
833
Reaction score
52
Location
Gloucestershire UK
Assuming this lathe is variable speed with a rotary knob/potentiometer to adjust the speed, it sounds very much like the potentiometer or the associated wiring is faulty.
 

NikNak

Established Member
Joined
9 Aug 2008
Messages
741
Reaction score
15
Location
Southampton
Hi Paul....


Yes that the model..... and yes that's what you guy at Axminster also reckoned.... :?



Nick
 

Chippygeoff

Established Member
Joined
19 Sep 2011
Messages
1,335
Reaction score
0
Location
Nr. Swansea
Hi Nick. This used to be a common problem with the 1220vs but i thought they had fixed it. I have had one since July and not had any problems with it. I find it a cracking lathe and does everything I want to do. Apparently when the problem you have occurs the control box is replaced with a totally different one so I have heard and is far superior than the old one.

Geoff.
 
Top