Quantcast

SQL Error this morning

UKworkshop.co.uk

Help Support UKworkshop.co.uk:

Digizz

Established Member
Joined
22 Jan 2004
Messages
384
Reaction score
0
Location
Oxfordshire
I got a real nasty SQL error this morning when trying to access the forums. Didn't copy the text unfortunately but it said something about the session table being full. I guess this is pretty much down to the Forum software though - but maybe some SQL setting?
 

woodshavings

Established Member
Joined
20 Mar 2003
Messages
714
Reaction score
0
Location
Alton, Hampshire
This was the error message:
phpBB : Critical Error

Error creating new session

DEBUG MODE

SQL Error : 1114 The table 'forum_sessions' is full

INSERT INTO forum_sessions (session_id, session_user_id, session_start, session_time, session_ip, session_page, session_logged_in) VALUES ('eee622ecad06d79bd7eab7a7c8a7b2a2', 149, 1095929952, 1095929952, '514f1560', 0, 1)

Line : 158
File : /home/ukworksh/public_html/forums/includes/sessions.php
 

Charley

Established Member
Joined
24 Aug 2002
Messages
2,072
Reaction score
2
Location
Collingham
Thanks for letting me know about this :)

The forum sessions table is getting full. It seems the search bots (mostly google,yahoo and msn) are flooding it. I emptied it but it's still filling up. I would of thought the forum software has something built in that clears it once it filled up, as if not we would of seen this error before but I'm guessing it's not working fast enough.

I've added a mod that only allows 5 sessions per IP address in the table at a time (if a new session is created for the IP the oldest one gets deleted). Let me know if you get any errors or if the forum seems slow.etc
 

Charley

Established Member
Joined
24 Aug 2002
Messages
2,072
Reaction score
2
Location
Collingham
Of course this isn't a good solution for those of you who are behind proxies so I have another plan but it takes a day or two to work. I'll keep you updated.
 

Digizz

Established Member
Joined
22 Jan 2004
Messages
384
Reaction score
0
Location
Oxfordshire
It only happened to me within a few minutes window this morning - not seen it since. Maybe the Forum is just too popular! :)
 

Alf

Established Member
Joined
22 Oct 2003
Messages
12,079
Reaction score
0
Location
Up the proverbial creek
It happened to me 3 or 4 times this morning. I'd ask what all this techie mumbo-jumbo means, but I'm afraid someone'll tell me. :shock:

Cheers, Alf
 

Charley

Established Member
Joined
24 Aug 2002
Messages
2,072
Reaction score
2
Location
Collingham
Is today the first time its happened to anyone?

Please let me know if it happens again although it *shouldn't* happen with this new temporary mod/patch.
 

dedee

Established Member
Joined
24 Jul 2003
Messages
2,637
Reaction score
1
Location
14860, France
Charley":ysswbem0 said:
Of course this isn't a good solution for those of you who are behind proxies so I have another plan but it takes a day or two to work. I'll keep you updated.
I'me one of those behind a proxy. Can'y say I've noticed anything strange all day.

Andy
 
A

Anonymous

Guest
Charley":3ncice0t said:
Is today the first time its happened to anyone?

Please let me know if it happens again although it *shouldn't* happen with this new temporary mod/patch.
I had it a couple of times this week on different days - first time was as I submitted a post
 

Alf

Established Member
Joined
22 Oct 2003
Messages
12,079
Reaction score
0
Location
Up the proverbial creek
Charley":4inlp2r7 said:
Is today the first time its happened to anyone?
'Tis for me. In fact I hadn't any trouble at all until Digizz mentioned it... Not that I'm apportioning blame obviously... :wink:

Cheers, Alf
 

ike

Established Member
Joined
24 May 2004
Messages
1,681
Reaction score
0
I got some kind of error this morning...gobbaldygook to me :? Bloody SQL's - 'spect the varmints chewed sum of the wiring..now where's me air rifle!
 

Charley

Established Member
Joined
24 Aug 2002
Messages
2,072
Reaction score
2
Location
Collingham
Okay I've taken the mod off as the search bots should now just ignore the forums.

Let me know if the SQL error ever pops up again..
 

Noel

Moderator
Staff member
Moderator
Joined
7 Aug 2003
Messages
6,165
Reaction score
70
Charley":1baxvl68 said:
Okay I've taken the mod off as the search bots should now just ignore the forums.

Let me know if the SQL error ever pops up again..
For about an hour around 6 this evening:

phpBB : Critical Error

Error creating new session

DEBUG MODE

SQL Error : 1114 The table 'forum_sessions' is full

INSERT INTO forum_sessions (session_id, session_user_id, session_start, session_time, session_ip, session_page, session_logged_in) VALUES ('9a38976bc8b0ae0f2807e65cd7a833d9', 212, 1107798347, 1107798347, '5167db90', 0, 1)

Line : 158
File : /home/ukworksh/public_html/forums/includes/sessions.php

Noel
 

Charley

Established Member
Joined
24 Aug 2002
Messages
2,072
Reaction score
2
Location
Collingham
Yes a few people have had the same error today...

I can't remember the 'temporary fix' I did back in Sept and the phpbb forums are down at the moment so I can't search for the answer.

I will have a play with the database and see if it solves anything. It may be that we have to wait till the phpbb forums are back online. Sorry about this everyone. I'll try and get it sorted ASAP..
 

Charley

Established Member
Joined
24 Aug 2002
Messages
2,072
Reaction score
2
Location
Collingham
Thanks to Google's 'cache' I was able to browse the phpbb forums and find what I hope is a fix.

Please let me know if this error pops up again..
 

Martin

Established Member
Joined
25 Jan 2003
Messages
202
Reaction score
0
Location
Guildford UK
Charley,

Possibly un-connected (excuse the pun - you'll see why shortly :wink:) - but in the last 10 mins or so I've had problems viewing both the front page and the forums.

The Events list on the front page included some text about SQL connect errors, and "too many connections". And the forums wouldn't display at all. Possibly UKW falling victim to its own success...?

regards,
Martin.
 

Aragorn

Established Member
Joined
6 Feb 2004
Messages
1,331
Reaction score
0
Location
East Sussex
Yep - I've just been having a problem too. Getting this message when trying to access the forum:
phpBB: Critical Error
Could not connect to database
 

Noel

Moderator
Staff member
Moderator
Joined
7 Aug 2003
Messages
6,165
Reaction score
70
Got that too, about 6PM or so. Got in through thr front door instead, rather than straight to the forums page.
 
Top