Quantcast
  • We invite you to join UKWorkshop.
    Members can turn off viewing Ads!

Problem with Sedgwick ta315 tilt mechanism

UKworkshop.co.uk

Help Support UKworkshop.co.uk:

Lawrence wickham

New member
Joined
22 Feb 2019
Messages
4
Reaction score
0
Location
Bournemouth
Hi everyone I’m having problems with my tilt mechanism on sedgewich ta315 . Blade will only tilt to about 80 degrees and locks up . Also vibrates slightly as I’m trying to tilt the blade . Any ideas on how to fix ? Thanks
 

kevinlightfoot

Established Member
Joined
11 Aug 2016
Messages
462
Reaction score
1
Location
Mansfield
I also have the same problems,do you have good dust extraction?I tend to clean mine regularly but access is difficult,when clean I use a dry lube on the screw I still get the vibrations though.This is the second 315 I have owned and the previous one was the same,an access panel on the front would be the answer to regularly keeping the screw cleaned.I also have trouble tilting to a full 45degrees but I don't need that function too often so I tend to ignore it.Dry lube and good extraction ever time you use it does help.
 

Trevanion

Greatest Of All Time
Joined
29 Jul 2018
Messages
3,775
Reaction score
557
Location
Pembrokeshire
As with most table saws, they just get dirty and need a good clean from time to time.

Blow it out with compressed air if you've got any and pack the tilt mechanism with grease on the screw. Any thoughts about grease and wood dust becoming dirty and wearing the screw faster is just nonsense so you don't need dry lubes, grease stays longer and will protect the gear from moisture. After all, when the machine is new all moving parts are greased are they not?
 

Lawrence wickham

New member
Joined
22 Feb 2019
Messages
4
Reaction score
0
Location
Bournemouth
Cheers guys found the problem it was one of the screws holding the silver ta315 signs on the front panel was catching on a bolt as it was lifting
 

Latest posts

Top