Quantcast
  • We invite you to join UKWorkshop.
    Members can turn off viewing Ads!

Hitachi C8FS armature removal

UKworkshop.co.uk

Help Support UKworkshop.co.uk:

Dajoca

Member
Joined
22 Feb 2018
Messages
9
Reaction score
0
Location
Devon
Bought an old 110v Hitachi C8FS mitre saw.
Went to use it yesterday and it turned on, then stopped.

Hoping it would be the brushes, I tried to remove them to check.
Jammed solid.

I cannot see how to get the brushes removed without removing the armature, but even with the motor assembly removed from the saw, the armature is stuck into the motor housing tightly.

Is it likely that it's jammed in there by the brushes, or is it possibly the armature bearing at the non open end of the housing, that is keeping it tightly in place.

The diagram doesn't appear to show any other locks or screws that I can see, that would lock the armature in.
The Dewalts seem to need a tap with a mallet at the closed end, but as this is a closed plastic case, I am looking at other options first.
Any thoughts on how to get this armature out?

Also, is there meant to be a brake on this, as when it does fire up the blade then takes a week to stop spinning.

Cheers
 

Dajoca

Member
Joined
22 Feb 2018
Messages
9
Reaction score
0
Location
Devon
Okay. Got the armature out by gripping the exposed bearing between the helical gear and the fan blades, and pulling hard.
The stuck bearing was held in place by some stiff, extra sticky, gloop.
That then made the removal of the stuck carbon brushes a much easier task.
 
Top