• We invite you to join UKWorkshop.
    Members can turn off viewing Ads!

Air Nailer Fault

UKworkshop.co.uk

Help Support UKworkshop.co.uk:

Freetochat

Established Member
Joined
14 Feb 2005
Messages
527
Reaction score
0
Location
Suffolk, UK
I have an Ace&K TYI-1664 15g brad air nailer which today has decided to develop a fault. What is happening is that when I connect the nailer to the air supply, the pin is firing without either trigger or safety plunger being depressed, and then the firing pin is remaining 'fired' and not returning back ready for the next application.

Has anyone any ideas as to the remedy for this please?
 

Mcluma

Established Member
Joined
2 Feb 2005
Messages
1,835
Reaction score
0
Location
Pyrford - Woking
take it appart, with the little set screw on the front, clean it, and then oil it,

Best is from now on to make sure that it stays clean, and every now and then put a bit of oil in the back on the gun (where you attache the airhose)

That should work
 

Freetochat

Established Member
Joined
14 Feb 2005
Messages
527
Reaction score
0
Location
Suffolk, UK
take it appart, with the little set screw on the front, clean it, and then oil it,

Best is from now on to make sure that it stays clean, and every now and then put a bit of oil in the back on the gun (where you attache the airhose)

That should work.
Mcluma - Tried your suggestion, I think I traced the fault down to a sticky trigger valve. I gave it a good clean and it worked, with a couple of fiddles when it got stuck again. Perhaps I will have to get a replacement valve.

Thanks for the advice
 
Top