• We invite you to join UKWorkshop.
    Members can turn off viewing Ads!

Administer CCL

UKworkshop.co.uk

Help Support UKworkshop.co.uk:

Michael Whiteoak

New member
Joined
4 Feb 2020
Messages
3
Reaction score
0
Location
Skelton TS12
Hi I have got a second hand ccl when I start my lathe it starts slow. Sometimes I have to turn it with my hand to get it spinning fast. Then it's ok . Is there anything I can do to stop it doing this.

Any advice would be greatly appreciated.

Michael
 

CHJ

Established Member
Joined
31 Dec 2004
Messages
20,130
Reaction score
73
Location
Cotswolds UK
I assume both motor and spindle run freely with no power applied, and belt is gripping well.

Is it easily stalled when running?

Sounds like the Start/Run Capacitor is on the way out.
 

Maca

Member
Joined
10 Jan 2020
Messages
7
Reaction score
0
Location
Aberdeen
Almost certainly the capacitor. Happened to me, replaced it for about £10 or £15 can't remember. Shortly after that it went too so just replaced the motor. Happy days.
 

Michael Whiteoak

New member
Joined
4 Feb 2020
Messages
3
Reaction score
0
Location
Skelton TS12
Thanks for your advice . Where will I get one .. I bought the lathe from a friend .And only just started turning .really enjoying it.
 

CHJ

Established Member
Joined
31 Dec 2004
Messages
20,130
Reaction score
73
Location
Cotswolds UK
Do a search on Google for Start and Run capacitors.
You need a run rated version, make sure the working voltage is at least as high as the current one, higher is better say 350-450 volt, , actual Mfd value not too critical ( 25-30 Mfd I suspect))
 
Top