Moderators: Random Orbital Bob, nev, Charley, CHJ, Noel

 Reply
User avatar
By nev
#1330056
GrahamF wrote:
fretnot wrote:The itech is not the same at all it may look the same with a passing glance but the itech is not the same quality I have first hand experience and have one sitting on my drive awaiting collection by s&s as I write this..
do not buy the itech machine


Can you explain?

I've had the iTech version for a few years and, having first looked at the overpriced SIP, am pretty certain it is the same except for colour. The wheel kit which came with it was a SIP boxed part and so was the spare riving knife which I bought to cut down. Have never regretted buying the iTech, it does what I want.


Don't hold your breath, Fretnot hasn't visited the site since 2014
User avatar
By GrahamF
#1330063
AndrewR86 wrote:Hi folks,
Sorry to piggyback the post...hope it’s ok with the admin.
It feels like there is something missing from the pad that runs along the guide rail.
Hope this makes sense. Thanks in advance!


Just compared mine with the photos posted and can't see any differences. Only thing which comes to mind - are the rails mounted too low so the fence is sitting on the table and not clamping properly?
User avatar
By Lons
#1330133
Graham
Just been out and checked mine again so here are a couple of picks with the fence clamped tight. maybe your pad is worn although I'd have thought you could take up wear with the adjustment nut.

There is a gap on mine of less than 1mm between bottom of fence and table, I don't know if it should be there or not but mine clamps perfectly.
You do not have the required permissions to view the files attached to this post.
User avatar
By GrahamF
#1330137
Lons wrote:Graham
Just been out and checked mine again so here are a couple of picks with the fence clamped tight. maybe your pad is worn although I'd have thought you could take up wear with the adjustment nut.


Hi Lons, mine is OK, it's Andrew who has the problem. G.
User avatar
By Lons
#1330161
GrahamF wrote:
Lons wrote:Graham
Just been out and checked mine again so here are a couple of picks with the fence clamped tight. maybe your pad is worn although I'd have thought you could take up wear with the adjustment nut.


Hi Lons, mine is OK, it's Andrew who has the problem. G.

Sorry Graham, must learn to read properly, maybe my missus is right and I can't multitask, trying to watch footie at the same time. :lol:
By AndrewR86
#1330189
Thanks for the advice guys.

My fence is sitting off the table, plenty of clearance.
088E24CA-F485-427E-B333-F0A8577ACFE1.jpeg


Only thing I can think that could be causing the issue is the plate at the back is bent. Possibly over tensioned at some stage. Will have a go at straightening it because as it is right now there is a lot of play in the entire fence.
022D713D-9620-49DA-A4C4-878CBCFD657A.jpeg


Thanks again for your input. If anything else pops to mind please fire it my way!
You do not have the required permissions to view the files attached to this post.